Print Page | Close Window

could not load... ecprocessor

Printed From: SalesCart
Category: Legacy Products
Forum Name: SalesCart NET
Forum Description: For SalesCart NET developers and designers to converse with other SalesCart NET owners
URL: http://forum.salescart.com/forum/forum_posts.asp?TID=561
Printed Date: July/23/24 at 7:46pm
Software Version: Web Wiz Forums 11.04 - http://www.webwizforums.com


Topic: could not load... ecprocessor
Posted By: thomas
Subject: could not load... ecprocessor
Date Posted: May/31/06 at 12:05pm
I've purchased the .net version.
I'm testing my first salescart on my localhost.

While trying to complete a purchase receipt1.aspx gave error of missing ecproccesor.dll.
I called support and the person email me the dll - told me to put it in the \bin directory - I did that.

Now I got a different error at the homepage.aspx

error:
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'ecprocessor' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Source Error:


Line 59:         &nb sp;       <add assembly="System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
Line 60:         &nb sp;       <add assembly="System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
Line 61:         &nb sp;       <add assembly="*" />
Line 62:         &nb sp;   </assemblies>
Line 63:         &nb sp;   <buildProviders>


Source File: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\web.con fig    Line: 61

***
If I removed ecprocessor.dll from the \bin folder the homepage.aspx open ok.

What is the problem?
Is this dll compatible with .net framework 2.0?




-------------
thoang



Replies:
Posted By: thomas
Date Posted: May/31/06 at 3:16pm
The problem is that ecprocessorstub.dll was incorrectly name as ecprocessor.dll.
The actual fix for the issue required two files: ecprocessor.dll and ecprocessorstub.dll.


-------------
thoang


Posted By: Bill
Date Posted: August/27/09 at 4:48pm
Hello;
I am having this same problem - where can the ecprocessorstub.dll be downloaded at?

-------------
Bill



Print Page | Close Window

Forum Software by Web Wiz Forums® version 11.04 - http://www.webwizforums.com
Copyright ©2001-2015 Web Wiz Ltd. - http://www.webwiz.co.uk