Print Page | Close Window

ecprocessor file

Printed From: SalesCart
Category: Legacy Products
Forum Name: SalesCart NET
Forum Description: For SalesCart NET developers and designers to converse with other SalesCart NET owners
URL: http://forum.salescart.com/forum/forum_posts.asp?TID=512
Printed Date: April/16/24 at 6:43pm
Software Version: Web Wiz Forums 11.04 - http://www.webwizforums.com


Topic: ecprocessor file
Posted By: wesonline
Subject: ecprocessor file
Date Posted: December/19/05 at 3:57pm
Purchased upgrade from Sales Cart PRO to .NET. Have been trying to complete the install and test my site. Got all the way to the last check out page and when the receipt page should be displayed I received an error relating to a missing file "ecprocessor".

I followed KB 5495 by calling tech support so that they could load the proper missing file into the cgi-bin folder. I was told to wait 30 minutes and test the system. I waited 2 hours, no fix. Called back on the 16th, tech did not place the file in the cgi-bin folder, new tech fixed it again. Waited several hours, still the same error.

Called back on the 16th and I was told by a third tech that I need to register the check out pages on my site with a WWW in front and without a WWW in front of the address. When attempting to register the first check out page on the non-WWW site I received the following error.

Server Error in '/' Application.
------------------------------------------------------------ --------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The located assembly's manifest definition with name 'ecprocessor' does not match the assembly reference.

Source Error:


Line 256:         &n bsp;     <add assembly="System.EnterpriseServices, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 257:         &n bsp;     <add assembly="System.Web.Mobile, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 258:         &n bsp;     <add assembly="*"/>
Line 259:         &n bsp;  </assemblies>
Line 260:


Source File: c:\winnt\microsoft.net\framework\v1.1.4322\Config\machine.co nfig    Line: 258

Assembly Load Trace: The following information can be helpful to determine why the assembly 'ecprocessor' could not be loaded.


=== Pre-bind state information ===
LOG: DisplayName = ecprocessor
(Partial)
LOG: Appbase = file:///e:/0/0/56/708/user/878/htdocs
LOG: Initial PrivatePath = bin
Calling assembly : (Unknown).
===

LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
LOG: Post-policy reference: ecprocessor
LOG: Attempting download of new URL file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/ca720fe1/17988597/ecprocessor.DLL.
LOG: Attempting download of new URL file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/ca720fe1/17988597/ecprocessor/ecprocessor.DLL.
LOG: Attempting download of new URL file:///e:/0/0/56/708/user/878/htdocs/bin/ecprocessor.DLL.
WRN: Comparing the assembly name resulted in the mismatch: NAME




------------------------------------------------------------ --------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET Version:1.1.4322.2032

Now when attempting to invoke dynamic.aspx or mall.aspx I get this same error. I called and got another service ticket on the 16th. I called this morning and there is no resolution. I called this afternoon and there is no update to this problem.

I have downgraded my .NET as instructed. I have replaced the DLL files in the BIN folder as instructed.

Any clues???



Replies:
Posted By: Selahbooks
Date Posted: December/19/05 at 6:14pm
I encountered the same problem several months ago regarding the missing ecprocessor.dll file. All I had to do was download the file to my cgi-bin and everything worked ok. I did not have to go through any registering of a www and a non-www. Sorry I can't help further.

-------------
Mike


Posted By: wesonline
Date Posted: December/19/05 at 7:40pm
Thanks for the input. I will keep on calling until they get it figured out.

Is selahbooks.com running .net with ASP or ASPX?

Thanks WES


Posted By: Selahbooks
Date Posted: December/20/05 at 11:01am
At this time Selah books is still using the .asp version. However, I do have one site up and running using .aspx and am almost ready to go live with another site using .aspx. I like the way it performs and so far the .aspx version is running smoothly.

-------------
Mike


Posted By: wesonline
Date Posted: December/21/05 at 11:32am
Mike a quick question if you don't mind.

Your new .NET sites using ASPX, are you also using a DYNAMIC site with an SQL products database? Also, are you hosted with COMCITY?

It seems that the errors I am having are related to that type of set-up, but if you are running with the same set-up then it must be someting else.

Thanks for your info!!!!

WES


Posted By: Selahbooks
Date Posted: December/21/05 at 1:42pm
Wes,
At this point I am using a Dynamic products database with MS Access. Sometime in the future I will need to upgrade to SQL.

I am not using COMCITY. My hosting company is www.dotnetpark.com. They have been very helpful and responsive to any questions or problems I have. The main problem I experienced when I first started using .NET was setting up the correct privledges. SalesCart support told me which privledges need to be set and once I had my host set those, I have had very few problems. Dotnetpark does not have telephone support, but they are excellent in responding to email questions. They offer a lot of features for a very reasonable cost. They also provide SQL databases at no extra charge.

If you ever decide to switch, contact me and I will send you the list of privledges that need to be set by the host.

Mike

-------------
Mike


Posted By: mikeb
Date Posted: January/03/06 at 2:44pm
Let me know if you are still having problems with this... Provide me your URL.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 11.04 - http://www.webwizforums.com
Copyright ©2001-2015 Web Wiz Ltd. - http://www.webwiz.co.uk